Xero - beautiful accounting software

Xero Developer Help Center

Xero Developer Community

Community > Add-ons >

X509 certificate (.cer) file for private Application

Started by sagar Patel -   in Add-ons

I have installed openssl-0.9.8h-1-setup in my windows desktop. And then through command prompt(run as admin) I have executed these code

openssl genrsa -out privatekey.pem 1024
openssl req -new -x509 -key privatekey.pem -out publickey.cer -days 1825
openssl pkcs12 -export -out public_privatekey.pfx -inkey privatekey.pem -in publickey.cer

it has generated a new folder with 3 main files "src" , "manifest", "uninstall". but in any of these folder I am not able to find x509.cer file.
but I did found one file named "cakey.pem" file. and when I tried uploading that file in xero while creating private app I am getting this error Message.

"Certificate public key has expired. The expiry date on the certificate is 7/5/1998 11:32:05 PM UTC."

do we need to have any licence version or some copy rights in order to generate this file?
Did you change directory to the bin folder first?

I did something like this:

cd C:\OpenSSL\bin

And then typed in those commands that you've executed. The .cer, .pem and .pfx files should all then appear in the bin directory that you navigated to.
 

Martin Blake  

You don't need anything else.
The files will have been created if there was no error message, but they will have been created in the directory your command line prompt indicated rather than any of the openssl folders you mentioned.

The name of the file you want to find is 'public key.cer' - do a search for that and you should fine the other created cert files in the same directory.
 

Ronan Quirke (Community Manager)  

Thanks for the suggestion martin. But there was no file named bin inside the openssl.
Then I created on directory named bin inside the openssl folder
Then when I ran the first code in command prompt i got an error saying openssl is not recognized as an internal or external command
 

sagar Patel  

I copied the openssl setup in bin folder and then tried running the code. then files got generated. But could not find the valid file.
I ran search through out the system but could not find the file named 'public key.cer'
 

sagar Patel  

X509 certificate (.cer) for IOS APP what is .cer
what should i upload
 

digittrix digi