Xero - beautiful accounting software

Xero Developer Help Center

Xero Developer Community

Community > API Authentication >

unable to load config info from /usr/loacal/ssl/openssl.cnf

Started by Karthik ji -   in API Authentication

Hi there,

i have downloaded and installed the openssl for windows in my computer.
in openssl command line run the below code

openssl> genrsa -out privatekey.pem 1024 -- > its successfully created the privatekey.pem

but i run the next line

openssl>req -new -x509 -key privatekey.pem -out publickey.cer -days 365 --- > its comes error msg as
"unable to load config info from /usr/loacal/ssl/openssl.cnf"

can you please help me on this. i followed the instruction whatever you given in your xero private authentication.

thanks
karthik
You might want to take a look at our instructions here, we have made two notes to prevent you hitting this error:
NOTE:
You may need to open the command prompt with elevated status (Run as administrator)
If the OpenSSL just recently installed, you might need to restart the computer
 

Ronan Quirke (Community Manager)  

Hi Ronan,

Thanks for you reply.i have already did the "Run as administrator" and also i restarted the computer. but it hitting the same error.

thanks
karthik
 

Karthik ji  

Then you might want to do some googling, there seems to be a number of search results with similar issues, though most seem to be pointing back to what we suggested above.

It isn't really possible for us to support a third party application that is running into problems on a particular PCcomputerso won't be able to help much further. All I suggest as an alternative is try running it on another computer.
 

Ronan Quirke (Community Manager)  

Thanks Ronan. Its working on another computer.. i need a one more help. i developed application as public. now i want to change private application. here is my public application code

OAuthHttpWebRequest httpRequest = new OAuthHttpWebRequest();
httpRequest.ConsumerToken = new OAuthToken { Token = m_ConsumerKey, TokenSecret = m_ConsumerSecret };
httpRequest.Token = new OAuthToken() { Token = m_AccessTokenKey, TokenSecret = m_AccessTokenSecret };
httpRequest.SetUri(p_EndPoint);
httpRequest.Method = "GET";


how to change this as private application.
 

Karthik ji  

Yet another 404. Where are the CURRENT instructions for creating the keys using OpenSSL?
 

Richard Rawlings