Xero - beautiful accounting software

Xero Developer Help Center

Xero Developer Community

Community > Getting Started >

TLS 1.0 Deprecation and the Xero API

Started by Xero API (Community Manager) -   in Getting Started

Xero will be deprecating TLS 1.0 Support via the Xero API on 30th June 2018.

It is recommended that all applications move to TLS 1.2 as the primary drivers for this change are:
  • Vulnerabilities in TLS 1.0
  • PCI-DSS compliance
  • Operating System, Development tools and Browser Support for more secure financial transactions


A post on the background TLS deprecation and the different SDK changes is available on Xero Devblog

Xero will be updating its official supported SDKs to support TLS 1.2 - these SDKs are found on developer.xero.com.

The purpose of this channel is to post any issues so that Xero and peers can assist developers in moving their applications off TLS 1.0
Official Xero Reply
I've updated the original post above to reference a devblog post which assists people using the SDKs to migrate their application.

For anyone who requires assistance, can you please provide the language you are using.

Thanks
 

Neil Grooby (Community Manager)