Xero - beautiful accounting software

Xero Developer Help Center

Xero Developer Community

Community > Getting Started >

Webhook's "Intent To Receive" never arrives to endpoint

Started by Sarah Corstange -   in Getting Started


I've created a Private App and wanted to verify the work of WebHooks.
After setting a simple PHP script to dump $_SERVER, $_REQUEST and $_POST variables I've initiated "Intent To Receive" request but nothing did arrive to my endpoint. I have tried to do this several times more (no success).
At the same time, my own requests to my endpoint were successfully logged.
I've tried to do the verification using ngrok (as it's explained in tutorial) and no luck again but my own requests work fine.

Do you know what can be done to receive ITR requests?
I had to delete and create webhook from the scratch. After this it started working.
This thread can be closed.

Sarah Corstange  

Had the same issue, same script on different servers had different results despite responding exactly the same. Deleting the webhook didn't make any difference.

Pointed a different domain at the same server that was broken and it started working. Something is clearly broken on Xero side where it is blocking a domain. I tried with a different sub-domain at first but that failed as well.

There is nothing unique about the domains, they are all very similar. Just seems a bit stupid that this is flagged as server not responding when it is Xero not attempting, likely due to previous failed attempts.

API User