Xero - beautiful accounting software

Xero Developer Help Center

Xero Developer Community

Community > Partner Program >

401 error response on authentication.

Started by Andrew Nester -   in Partner Program

Hello!

We are using Partners API.
We've migrated our application according Entrust Certificate Deprecation guide a month ago.
It worked fine till June 11-12, 2017.

Since that time we started receiving 401 errors from calls to https://api.xero.com/oauth/AccessToken
The response error message is not much informative, it looks like this:

oauth_problem=signature_invalid&oauth_problem_advice=Failed%20to%20validate%20signature

Should it be fixed on our side? Or on Xero side? How can we do it?
We need this to be fixed ASAP because we can't use API at all because of this.

Thanks!
Hi Andrew,

May we know the name of the application so we can investigate?

Tried to search for any application registered under your name but found none.
 

Welli Abdullah (Xero Staff)  

Hi Welli!

Thanks for reply, we've fixed our issue.
The problem was that certificate expired.
It's a bit weird because we don't use it (we're completed all steps according Entrust Certificate Deprecation)
Once we're renew our certificates in Xero App, everything started to work again
 

Andrew Nester  

Thanks for the clarification.

Actually that certificate is still needed by the app to RSA-SHA1 signing the OAuth requests - https://developer.xero.com/documentation/auth-and-limits/entrust-certificate-deprecation
 

Welli Abdullah (Xero Staff)