Xero - beautiful accounting software

Xero Developer Help Center

Xero Developer Community

Community > Getting Started >

How to make private/public key pair using OpenSSL ?

Started by Sohag Biswas -   in Getting Started

Hello, I'm a Xero newbiw and trying to integrate Xero with WooCommerce. Here I'm trying to make a private/public key pair as instructions . But a term i don't understand . What does mean "To run the commands below, go to the OpenSSL32 directory on your PC, and change to the /bin directory." ? I've OpenSSL installed. But can't able to command on CommandPrompt . Any help ?
Hopefully the following link on Command Prompt basics can help - http://dosprompt.info/

The "Moving Between Folders, Listing Folder Contents" section is the most relevant to your question.

Please note that you need to open/run the OpenSSL commands on elevated command prompt - How do I open an Elevated Command prompt
 

W. Abdullah (Community Manager)  

Hi Abdullah, Thanks for your reply. Still i don't know what does mean "change to the /bin directory." Can you pls show me how to make "private/public key" pair ? That'd help me a lot.
 

Sohag Biswas  

Hi Sohag,

I can give you the following steps to create the key pair using OpenSSL

1. As you have already installed OpenSSL, first open your command prompt (run as administrator)
2. Goto OpenSSL/bin directory. For example, if you have OpenSSL installed in C drive, give the command cd OpenSSL-Win64/bin once you are in C prompt. Depending on your OpenSSL version, the directory name can vary, the above command is based on the 64 bit version OpenSSL installed.
3. Now you are in the bin directory and you can run the commands given in the instructions page

Hope this is clear enough for you to understand
 

Samitha N (Xero Staff)  

Hello Sam,
Thanks. I understood your clear direction. But NOT working. I've attached a screenshot. Would you pls see this?

http://imgur.com/fg3eYGy
 

Sohag Biswas  

Hello , Seems OpenSSL ins't working on my windows 7. So I've tried on Mac and successfully created . But now the question is where is the public/private key files created ?
 

Sohag Biswas  

Hi Sohag,

Happy to know that you made some progress. You are unable to locate the openssl directory in windows, because your command was wrong. To specify the path to a folder/file, you have to use backslashes in windows. You have used OpenSSL32/bin, use backslashes instead. In my answer above, i was just showing you how the command will look in general, but windows uses backslashes, but Unix based systems uses forward slashes.

Anyway, as you have generated your public/private keypair in Mac, you can find them in the same folder where you tried to create them. If you were in the OpenSSL32/bin, look for the files in the same folder
 

Samitha N (Xero Staff)  

Hello - I am trying to integrate WooCommerce with Xero on my Wordpress site. I have followed the instructions on WooCommerce docs here https://docs.woocommerce.com/document/xero/#section-5 but in section 5 I get stuck as my hosting is on Wordpress and I am unable to upload the documents here
 

Kirren Chapman