Xero - beautiful accounting software

Xero Developer Help Center

Xero Developer Community

Community > API Endpoints >

Invoice API not showing errors in history. Invoices not generating in account.

Started by Eva S Raczine -   in API Endpoints

Hello.

This is an odd error. The invoices were inserting fine. But now have stopped.
In the API call history they all still have 200 responses.

Is there anything that has changed to stop the invoices showing in the Xero account?

Here is an example call that the API says is fine but does not generate an invoice in the account.

```
<Invoices>
<Invoice>
<Type>ACCREC</Type>
<Contact>
<ContactID>xxxxxx</ContactID>
<ContactStatus>ACTIVE</ContactStatus>
<Name>Customer Name</Name>
<FirstName>Customer</FirstName>
<LastName>Name</LastName>
<EmailAddress>info@example.com</EmailAddress>
<Addresses>
<Address>
<AddressType>STREET</AddressType>
</Address>
<Address>
<AddressType>POBOX</AddressType>
<AddressLine1>add1</AddressLine1>
<AddressLine2>add2</AddressLine2>
<City>city</City>
<PostalCode>aa0 1bb</PostalCode>
</Address>
</Addresses>
<Phones>
<Phone>
<PhoneType>DDI</PhoneType>
</Phone>
<Phone>
<PhoneType>DEFAULT</PhoneType>
</Phone>
<Phone>
<PhoneType>FAX</PhoneType>
</Phone>
<Phone>
<PhoneType>MOBILE</PhoneType>
<PhoneNumber>01234567890</PhoneNumber>
</Phone>
</Phones>
<IsSupplier>false</IsSupplier>
<IsCustomer>true</IsCustomer>
<UpdatedDateUTC>2022-06-12T14:43:44+00:00</UpdatedDateUTC>
<HasAttachments>false</HasAttachments>
</Contact>
<LineItems>
<LineItem>
<Description>line item Desc</Description>
<Quantity>60</Quantity>
<UnitAmount>2.95</UnitAmount>
<AccountCode>200</AccountCode>
<TaxType>NONE</TaxType>
</LineItem>
</LineItems>
<DueDate>2022-07-26</DueDate>
<Reference>Invoice refference </Reference>
<CurrencyCode>GBP</CurrencyCode>
<Status>SUBMITTED</Status>
</Invoice>
</Invoices>
```


Any advice?
Thanks In advance!