Xero - beautiful accounting software

Xero Developer Help Center

Xero Developer Community

Community > Wrapper libraries >

Unable to send contact postal address via API

Started by Matt Roberts -   in Wrapper libraries

I am using the Xero.NetStandard.OAuth2 nuget package. When sending a new contact via xeroAccountingApi.UpdateOrCreateContactsAsync() the contact postal address does not take in Xero.

I send over both a delivery and postal address on the contact. The only difference between them is the address type. However, the contact that is returned is missing the postal address. If I look on the Xero website this confirms that only the delivery address has been included and the postal address is missing.

I can't find any details about specific requirements for the postal address in the API documentation.

I have tried sending the postal address by itself (i.e. no other address types) without success. I have also tried updating the contact (same method on the API), and although Xero acknowledges the contact has been updated there is still no postal address on the contact.

Has anyone else experienced this, or know of a possible reason for this behaviour?

Many thanks in advance for any assistance.
Hi Matt - it sounds like there is something in the SDK that is dropping the API params.

You can confirm this by finding your API call in the history tab: https://imgur.com/a/nI1uy7d


If you still can't figure out how to structure the params you should open an issue on the repo and our maintainers can try and address if directly - https://github.com/XeroAPI/Xero-NetStandard/issues

Christopher Knight (Xero Staff)